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1. Introduction 
The Microsoft Office 2010 suite has many new features and functionality that can be 
used to enhance the accessibility of Microsoft Word, Excel and PowerPoint documents. 
These features, in conjunction with the functionality already available in the software, 
create a program that enables the accessibility of Microsoft Office 2010 documents. 



  

 
These features and functionality should be applied to source documents to assist every 
individual who will read, use, create or navigate the document. It requires creating 
documents in a manner that encompasses the concept of universal design 
(inclusiveness and equitable access for all regardless of age, ability or status in life). As 
an example, by using a font size of 12pt or higher it creates content that can be more 
clearly read; by using styles and formatting to add headings to a document the structure 
can be more easily identified and navigated by all; or finally, by providing meaningful and 
descriptive hyperlink text a user can clearly understand the context and purpose of a 
link. By designing source documents with accessibility in mind, all users benefit.  
 
Even if the final format of the document will not be the same as the format it was created 
in, it is still important to design the document with accessibility in mind. Much of the 
functionality applied to a source document will be transferred over to the new format 
during the conversion process (e.g. from Word to PDF, etc.).  
 

2. Terms of Use 
While the instructions and techniques discussed in this guide will help enhance the 
accessibility of Word documents, it does not guarantee accessibility. It is recommended 
that an automated and manual assessment of the Word document(s) be completed to 
identify any accessibility issues that require remediation. In addition, it is recommended 
that a person proficient in the use of assistive technology test the document(s) to verify 
accessibility, when possible.  

3. Styles & Formatting 
3.1 Format 

As mentioned previously, it is important to design the source document with accessibility 
in mind. This includes the general text and formatting of the document itself. Below are a 
few general text and formatting tips for enhancing the accessibility of Microsoft Word, 
PowerPoint and Excel documents. This list is by no means exclusive, but it will provide 
some key tips for improving the accessibility of these documents.  

• Use a 12 point font or greater for text;  

• Choose typefaces that are sans serif or non fancy (e.g. Arial or Verdana) – see 
additional information about sans-serif fonts in section 3.1.1;  

• Use fonts of normal weights;  

• Set font colour to ‘Automatic’ or ‘Black’; 

• Avoid large amounts of text set in all caps, italics or underline; 

• Add sufficient white space between text and graphics; 

• Avoid using animated, flashing or scrolling text. 



  

3.1.1 Typeface 
Typefaces are typically described as serif or sans-serif (e.g. with or without serifs). Serifs 
are small embellishments at the end of letter strokes that are typically used for 
decoration. Serif fonts are generally more difficult to read as they are more decorative in 
nature and are likely to have more of a hand written, cursive or italic style. Sans-serif 
fonts are generally clean, modern and simple font styles that are easier to distinguish on 
the screen. 
 
Below is an example of two different typefaces (left with serifs; right without):  

 
Figure 1: This example shows a typeface (Perpetua) with a decorative 
embellishment called a serif and a typeface (Arial) with no serifs. 

3.2 Use of Colour 
The use of colour is also important in improving the accessibility of a document. The 
Web Content Accessibility Guidelines (WCAG) 2.0 Level AA advises that foreground and 
background colours have a contrast ratio of at least 4.5:1 (with a few exceptions). The 
recommended colour combination is black text on white background or white text on a 
black background as this provides a very high contrast allowing for easier reading.  
Below are some examples of high and low colour contrasts:  
 
High Colour Contrast Examples:  

 

 

 
 
Low Colour Contrast Examples:  

http://www.w3.org/TR/WCAG20/


  

 

 

 
 
A useful tool for checking colour contrast is the Juicy Studio Luminosity Colour Contrast 
Ratio Analyzer which allows the user to input the hex numbers for the background and 
foreground colours to calculate the contrast ratio and determine if it meets the WCAG 
2.0 criteria.  
 
In addition, a single solid colour should be used for a background rather than a patterned 
background. A solid background colour allows the text to be read more easily than 
having a pattern which distracts from the text and makes the text harder to read. Below 
are some examples to demonstrate:  
 
Single Solid Colour Background Example:  

 
Patterned Background Example:  

 

3.3 Hyperlinks 
When developing content for a document, ensure all hyperlinks have meaningful text 
descriptions and provide sufficient context as to the purpose of the hyperlink. Hyperlinks 
can be used as navigation aids within a document and should make sense when read in 
context, therefore, always use a text description that is meaningful when creating a 
hyperlink.  
For example, if there was a hyperlink in this document that pointed to the Ryerson 
University internet site, the text description for the hyperlink should not simply state ‘Click 
here’ as the text has no meaning and it is not entirely clear where the hyperlink will take 
the reader once activated. A more meaningful and descriptive hyperlink would be ‘Ryerson 
University internet site’.  

 
 
How to Add a Hyperlink in a Document:  

http://juicystudio.com/services/luminositycontrastratio.php
http://juicystudio.com/services/luminositycontrastratio.php


  

(a) Select the Insert tab in the ribbon bar;  
(b) Select the Hyperlink button; 

 
(c) In the Insert Hyperlink dialogue box that appears, add the URL to the Address 

field; 
(d) Add text into the Text to Display field. Please note that the content added to this 

field will be shown as the text description on the page. This text should be 
meaningful and descriptive so a reader will understand where the link will go 
once activated.  

(e) Select OK. 

 
 
How to Add a Hyperlink to Existing Text on the Page:  

(a) Highlight the text on the page where the hyperlink will be created;  
(b) Select the Insert tab in the ribbon bar;  
(c) Select the Hyperlink button;  
(d) In the Edit Hyperlink dialogue box that appears, add the URL to the Address 

field;  
(e) The Text to Display field will be unavailable and state “<<Selection in 

Document>>”. The text that will be displayed for the hyperlink has already been 
highlighted and selected on the page.  

(f) Select OK.  



  

 

3.4 Headings 
Design Word documents using styles (e.g. Heading 1, Heading 2, Body Text) as they:  

(a) add the structure necessary for content to be accessed from the general to the 
specific; 

(b) order the headings to provide meaningful sequence to assistive technology 
users; and 

(c) allow users of text-to-speech software to use the headings to navigate through 
the document without having to read all the content.  

 
Headings should progress in a hierarchical manner based on the content (e.g. Heading 
2 should come after Heading 1). Styles and formats can be viewed and modified using 
the Quick Styles Gallery (see instructions below).  
 
Headings should be used to separate paragraphs instead of simply using the enter key 
to apply manual spacing. All content within the document should have a style applied to 
it with the “Normal” heading only used when it contains body content.  It is important to 
use the default heading styles provided in Word, rather than creating custom headings. 
Experience shows that custom headings may not be properly recognized by screen 
reading technology. Customizing styles to achieve a specific layout (e.g. specific 
typeface and font size, etc.) can still be achieved by using default headings – see 
instructions below.  
 
To apply heading styles to your document:  

(a) Highlight the text on the page to apply the heading style;  
(b) Select the Home tab in the ribbon bar;  
(c)  In the Style group, select the appropriate level heading from the Quick Styles 

Gallery.  



  

 
 
To modify a heading style:  

(a) Select the Home tab in the ribbon bar; 
(b)  In the Styles group, right-click the style that requires modification from the 

Quick Styles Gallery;  
(c) Select Modify from the menu that appears; 

 
(d) In the Modify Style dialogue box, make the necessary changes to the formatting 

(e.g. font size, typeface, colour, justification, etc.); 
(e) Select OK.  



  

 

4. Layout & Structure 
4.1 Tables 

The table feature in Word should always be used rather than manually spacing using the 
TAB key or space bar to simulate a table. Tables should only be used for tabular 
information. They should not be used for formatting and layout. For increased usability, 
tables should be structured with no merged cells, blank cells or nested tables. If the data 
contained in a table is complex, the data sets should be divided into smaller tables rather 
than have one large complex table.    
 
Each table should have marked table headers. Please ensure that the header cells are 
clear and concise. 
 
To specify a header row in a table:  

(a) Place the cursor in any cell within the table; 
(b) Select the Table Tools-Design tab in the ribbon bar; 
(c) In the Table Style Options group, select the Header Row check box. This will 

apply special formatting and structure for the first row in the table.  



  

 
Note: Presently, when the headers are specified in a table this information is not being 
communicated to assistive technologies. As an alternative for Job Access with Speech 
(JAWS) users, bookmarks can be added to tables to specify the headers in a table and 
provide easier navigation – see instructions for inserting bookmarks below.  
 

For tables that have row and column headers:  
(a) Place the cursor in the cell where the row and header columns meet;  
(b) Select the Insert tab in the ribbon bar;  
(c) In the Links section, select Bookmark;  
(d) Type ‘Title_1’ and press enter. 
 

For tables that have only column headers:  
(a) Place the cursor in the first column of the table containing the header;  
(b) Select the Insert tab in the ribbon bar;  
(c) In the Links section, select Bookmark.  
(d) Type ‘ColumnTitle_1’ and press enter.  

 
For tables that have only row headers:  

(a) Place the cursor in the first column of the table containing the header; 
(b) Select the Insert tab in the ribbon bar; 
(c) In the Links section, select Bookmark. 
(d) Type ‘RowTitle_1’ and press enter.   

 
Please note: only one bookmark per table is required as JAWS will recognize the 
entire marked row and/or column as table headings.  
 
In addition, the repeat headers at top of page option should be turned on to assist with 
the flow of information.  
To turn on repeat headers option:  

(a) Place the cursor in any cell within the table; 
(b) Select the Table Tools-Layout tab in the ribbon bar;  
(c) In the Data group, select the Repeat Header Rows button. 

 

4.2 Lists 
It is important when creating a Microsoft Word documents to use the functionality 
available in the software itself for layout and formatting. Use real lists in the document 
instead of simulating lists using the TAB key or space bar. This also applies to 
numbering, tables and other layout formatting tools available in Word.   



  

4.3 Table of Contents 
When creating long documents, it is recommended that a hyperlink enabled table of 
contents is inserted near the beginning of the document. By having an interactive table 
of contents, the user can navigate to specific sections directly, without having to read the 
entire document.  
 
The heading structure of the document is used to create the table of contents by 
providing the needed structure. For more information on headings, see section. 3.4.  
 
To insert a table of contents:  

(a) Place the cursor in the document where the table of contents will be situated; 
(b) Select the References tab in the ribbon bar;  
(c) In the Table of Contents group, select Table of Contents;  
(d) Select a desired style for the table.  

 
 

To update the table of contents:  



  

(a) Select the table of contents in the document (note: the table of contents will 
appear highlighted when selected);  

(b) Select the References tab in the ribbon bar;  
(c) In the Table of Contents group, select the Update Table button.  

 

4.4 Specifying Language 
Some screen reader technologies have the ability to switch to the appropriate spoken 
language by identifying the language for the document. By using the correct language 
setting in Word, it allows the screen reader technology to correctly enunciate the content 
in the document. 
 
To indicate the language of a selected section of text:  

(a) Highlight the section of text that requires a specific language (note: if the entire 
document is written in one language, select all of the text in the document);  

(b) Select the Review tab in the ribbon bar;  
(c)  In the Language group, select the Language button; 
(d) Select the Set Proofing Language option from the menu that appears;  

 
(e) In the Language dialogue box that appears, choose the appropriate language 

from Mark Selected Text As list.  
(f) Select OK. 



  

 
To detect language automatically for the entire document:  

(a) Select the Review tab in the ribbon bar;  
(b)  In the Language group, select the Language button; 
(c) Select the Set Proofing Language button from the menu that appears;  
(d) In the Language dialogue box that appears, select the Detect Language 

Automatically check box; 
(e) Select OK.   

 



  

5. Images & Objects 
5.1 Alternative Text for Images & Objects 

Alternative text is read by screen readers to provide assistive technology users with a 
description of the image or graphic. When a screen reader comes across an image with 
no alternative text, a couple of things may occur:  

• The image is skipped (as if it did not exist on the page);  

• The file name associated with the image is read to the user (e.g. img1245.gif).  
When creating an alternative text description, ensure the text alternative communicates 
the purpose and meaning of the image and/or graphic.  
 
An alternative text description should be a short description of the image. If the image is 
complex and requires a longer description, it is recommended that the image receive a 
short alternative text description and a longer description be provided as text on the 
page. Ensure that any images of text are replicated in the description.  
 
Alternative text can be included for the following objects in Microsoft Word 2010: 
pictures, clipart, charts, tables, shapes, SmartArt graphics, groups (all but shapes), 
embedded objects, ink, etc.  
 
To add alternative text:  

(a) Right-click on the image or object;  
(b) Select Format Picture from the menu that appears;  

o For tables, select Table Properties from the menu that appears;  



  

 
(c) Select Alt Text from the left hand column in the Format dialogue box. Alt Text 

will be the last option in the left column;  
(d) Insert a meaningful and descriptive alternative text of the image or object in the 

Title field. There is an additional field labeled Description that can be used to 
provide more detail about the image or object. According to Microsoft 
documentation, “a title can be read to a person with a disability and is used to 
determine whether they wish to hear the description of the content.”  

(e) Select Close.   



  

 
 

Another feature of the Microsoft Word 2010 application is the ability to add commands to 
the Quick Access Toolbar for frequently used commands. The Alt. Text command can 
be added to the Quick Access Toolbar so the author can easily access the command.   
  
To add the Alt. Text command to the Quick Access Toolbar: 

(a) Select the Customize Quick Access Toolbar button in the top left corner of the 
application (above the ribbon bar); 

 
(b) Select the More Commands option in the menu that appears;  



  

 
(c)  A Word Options dialogue box will appear. In the Choose Commands From 

drop-down menu, select Commands not in the Ribbon;  
(d) In the Commands list, select Alt Text; 
(e) Select the Add button.  
(f) Select OK.  



  

 
 
To use the Alt. Text command after adding it to the Quick Access Toolbar:  

(a) Select the shape, picture, chart, SmartArt graphic, table or other object;  
(b) Select the Alt Text command button in the Quick Access Toolbar (top left 

corner of the application – above the ribbon bar). This will open the Format 
dialogue box automatically to the Alt Text option;  

 
(c) Enter text into the Title and Description fields as appropriate. 
(d) Select Close.   



  

5.2  “Floating” Elements 
Text boxes should be avoided in a document as they are generally inaccessible by 
screen reader technology. As an alternative, content should be placed directly on the 
page itself. This same rule applies to watermarks, so it is best to avoid using them 
altogether unless the text content or described graphic of the watermark is included in a 
logical place within the document.  
 
In addition, objects in a document should be inserted as inline objects. While this is done 
by default, they occasionally may be inserted as or changed to floating elements. An 
inline object keeps its position on the page relative to a portion of text, whereas, a 
floating object keeps its position relative to the page regardless of the flow of text behind 
it. With a floating object, the element can be positioned anywhere on the page, including 
in front of text, creating numerous accessibility issues.  
 
To change the position of an object to be inline with text:  

(a) Select the object; 
(b) Select the Picture Tools – Format tab from the ribbon bar;  
(c) In the Arrange group, select the Wrap Text button;  
(d) Select the In Line With Text option from the menu that appears.  

 

6.  Checking for Accessibility  
A new accessibility feature in Microsoft Word, Excel and PowerPoint 2010 is the 
Accessibility Checker. This tool will assist authors to proactively identify accessibility 
issues in a document. The tool highlights potential problems and recommends 
application specific tips to assist in the remediation of any identified issues.  
 
The Accessibility Checker identifies issues based on a pre-determined set of rules that 
may prevent users from fully accessing the content of a document. Three categories of 
issues can be identified:  

• Errors: Issues identified as errors could potentially make it very difficult or 
impossible for persons with disabilities to fully access and understand content.   



  

• Warnings: Issues identified as warnings may cause difficulties, in some cases, 
for persons with disabilities to access and understand content.  

• Tips: Issues identified as tips are recommendations for better organization of 
content to ensure the content is presented effectively and efficiently.  

For more information on the Accessibility Checker rules, refer to section 6.1.  
 
Once the Accessibility Checker tool has completed its analysis, information about each 
potential issue is presented in the Accessibility Checker task pane (Inspection Results). 
Each issue can be selected by the user, which in turn, reveals more information about 
how to remediate the selected issue. 
 
To use the Accessibility Checker Tool:  

(a) Select the File tab in the ribbon bar;  
(b) Select Info from the left hand column;  
(c) Under the Prepare for Sharing section, the user will initially be informed if any 

issues have been found in the document. For example, the alert may state: 
“Before sharing this file, be aware that it contains…content that people with 
disabilities are unable to read…”  

(d) Select the Check for Issues button; 
(e) Select Check Accessibility from the drop-down menu that appears;  



  

 
(f) After the check is completed, the Accessibility Checker task pane (Inspection 

Results) will open on the right hand side of the document showing the results.  

 



  

When a specific issue is selected in the Inspection Results list, information in the 
Additional Information section of the task pane will provide recommendations for 
remediation for the selected issue. 

• NOTE: The additional information section can be navigated by using the 
mouse to scroll down through the information or by pressing F6 to focus on 
the task pane, tabbing until the focus is in the Additional Information area 
then proceeding to scroll using the keyboard.  

 
 
The Accessibility Checker command can also be added to the Quick Access Toolbar so 
the author can easily access the command. The I&IT Accessibility Centre of Excellence 
(ACOE) highly recommends that all OPS staff add the Alt. Text and Accessibility 
Checker commands to the Quick Access Toolbar in Word, PowerPoint and Excel 2010.  
  
To add the Accessibility Checker command to the Quick Access Toolbar: 

(a) Select the Customize Quick Access Toolbar button in the top left corner of the 
application (above the ribbon bar); 



  

 
(b) Select the More Commands option in the menu that appears;  

 
(c) A Word Options dialogue box will appear. In the Choose Commands From 

drop-down menu, select Commands not in the Ribbon;  
(d) In the Commands list, select Accessibility Checker; 
(e) Select the Add button.  
(f) Select OK.  



  

 
 
To use the Accessibility Checker command after you have added it to the Quick 
Access Toolbar:  

(a) Select the Accessibility Checker command in the Quick Access Toolbar; 
(b) The document will automatically be checked for accessibility issues. Any 

identified issues will be shown in the Inspection Results list located on the right 
hand side of the document.  

 

6.1 Accessibility Checker Rules 
The following rules may be checked against during an accessibility check in Microsoft 
Word, Excel and PowerPoint 2010. For each rule, recommendations for remediation are 
provided to the user.  



  

6.1.1 Error Rules 
Rule Name* Applicable Application 
All objects have alternate text Excel, PowerPoint, Word 

Tables specify column header information Excel, PowerPoint, Word 

All slides have titles PowerPoint 

Long document use styles to provide structure Word 

* A detailed explanation of each error rule can be found on the Microsoft 
Accessibility Support website under Accessibility Checker Rules.  

6.1.2 Warning Rules 
Rule Name* Applicable Application 
Hyperlink text is meaningful Excel, PowerPoint, Word 

Table has simple structure Excel, PowerPoint, Word 

Table don’t use blank cells for formatting Excel, PowerPoint, Word 

Sheet tabs have non-default names Excel 

Avoid the use of repeated ‘blank’ characters Word 

Headings don’t contain too much information Word 

The use of floating objects is avoided Word 

* A detailed explanation of each warning rule can be found on the Microsoft 
Accessibility Support website under Accessibility Checker Rules.  

6.1.3 Tip Rules 
Rule* Applicable Application 
Closed captions are included for inserted audio and 
video 

Excel, PowerPoint, Word 

The reading order of a slide should be logical PowerPoint 

The slide titles in a deck should be unique PowerPoint 

Layout tables are structured for easy navigation Word 

No image watermarks are used Word 

All headings are in the correct order Word 

*A detailed explanation of each tip rule can be found on the Microsoft 
Accessibility Support website under Accessibility Checker Rules.  
 

http://office.microsoft.com/en-us/support/?CTT=97
http://office.microsoft.com/en-us/support/?CTT=97
http://office.microsoft.com/en-us/word-help/accessibility-checker-rules-HA101823437.aspx
http://office.microsoft.com/en-us/support/?CTT=97
http://office.microsoft.com/en-us/support/?CTT=97
http://office.microsoft.com/en-us/word-help/accessibility-checker-rules-HA101823437.aspx
http://office.microsoft.com/en-us/support/?CTT=97
http://office.microsoft.com/en-us/support/?CTT=97
http://office.microsoft.com/en-us/word-help/accessibility-checker-rules-HA101823437.aspx


  

6.2  Manual Assessment  
In addition to using the built-in Accessibility Checker to complete an automated 
accessibility assessment of a document, a manual assessment will also need to be 
completed.  
 
The purpose of a manual assessment is to apply more judgment to an assessment to 
catch and identify qualitative issues that might be missed or cannot be determined by an 
automated assessment tool.  For example, manual testing is used to assess that the 
alternative text provided for an image is an appropriate and meaningful description of the 
image or that colour contrast minimums have been met, etc.  
 
Please refer to the manual assessment checklist for Word 2010 documents for more 
information. Please note that this checklist is by no means a comprehensive list of all 
manual checks to be completed, however, it provides a great starting point and quick 
reference.  
 

7. References & Additional Help  
7.1 Access Ryerson Resources 

Accessibility At Ryerson 
DMP office - Web accessibility 
 

7.2 Microsoft Office Support 
Microsoft Office Support Website – Word Help and How-To 
Microsoft Office Support – Creating Accessible Word Documents 
Microsoft Office Support – Accessibility Features in Word 
Microsoft Office Support – Accessibility Checker 
Microsoft Office Support – Accessibility Checker Rules  

 

7.3 Additional Resources   
OPS Diversity Office Accessible Document Resources 
Accessible Digital Office Documents (ADOD) Project 
Juicy Studio Luminosity Colour Contrast Ratio Analyzer 

http://10.77.8.43/acoe_docs/2010_DOCS/Microsoft%20Word%202010%20Manual%20Assessment%20Checklist%20v1.0.pdf
http://ryerson.ca/accessibility/
http://www.ryerson.ca/dmp/accessibility/index.html
http://office.microsoft.com/en-us/word-help/word-help-and-how-to-FX101818070.aspx?CTT=97
http://office.microsoft.com/en-us/word-help/word-help-and-how-to-FX101818070.aspx?CTT=97
http://office.microsoft.com/en-us/word-help/creating-accessible-word-documents-HA101999993.aspx?CTT=1
http://office.microsoft.com/en-us/word-help/accessibility-features-in-word-HP010370103.aspx?CTT=1
http://office.microsoft.com/en-us/word-help/accessibility-checker-HA010369192.aspx?CTT=1
http://office.microsoft.com/en-us/word-help/accessibility-checker-rules-HA101823437.aspx
http://intra.net.gov.on.ca/diversity/accessibility/resources/accessible-documents/
http://adod.idrc.ocad.ca/
http://juicystudio.com/services/luminositycontrastratio.php
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